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Legal Information
The information provided in this document contains general descriptions, technical
characteristics and/or recommendations related to products/solutions.

This document is not intended as a substitute for a detailed study or operational and
site-specific development or schematic plan. It is not to be used for determining
suitability or reliability of the products/solutions for specific user applications. It is the
duty of any such user to perform or have any professional expert of its choice
(integrator, specifier or the like) perform the appropriate and comprehensive risk
analysis, evaluation and testing of the products/solutions with respect to the relevant
specific application or use thereof.

The Schneider Electric brand and any trademarks of Schneider Electric SE and its
subsidiaries referred to in this document are the property of Schneider Electric SE or
its subsidiaries. All other brands may be trademarks of their respective owner.

This document and its content are protected under applicable copyright laws and
provided for informative use only. No part of this document may be reproduced or
transmitted in any form or by any means (electronic, mechanical, photocopying,
recording, or otherwise), for any purpose, without the prior written permission of
Schneider Electric.

Schneider Electric does not grant any right or license for commercial use of the
document or its content, except for a non-exclusive and personal license to consult it
on an "as is" basis.

Schneider Electric reserves the right to make changes or updates with respect to or in
the content of this document or the format thereof, at any time without notice.

To the extent permitted by applicable law, no responsibility or liability is
assumed by Schneider Electric and its subsidiaries for any errors or omissions
in the informational content of this document, as well as any non-intended use
or misuse of the content thereof.
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Safety Information

Important Information
Read these instructions carefully, and look at the equipment to become familiar
with the device before trying to install, operate, service, or maintain it. The
following special messages may appear throughout this documentation or on the
equipment to warn of potential hazards or to call attention to information that
clarifies or simplifies a procedure.

Please Note
Electrical equipment should be installed, operated, serviced, and maintained only
by qualified personnel. No responsibility is assumed by Schneider Electric for any
consequences arising out of the use of this material.

A qualified person is one who has skills and knowledge related to the construction
and operation of electrical equipment and its installation, and has received safety
training to recognize and avoid the hazards involved.

The addition of this symbol to a “Danger” or “Warning” safety label indicates that an 
electrical hazard exists which will result in personal injury if the instructions are not 
followed.

This is the safety alert symbol. It is used to alert you to potential personal injury 
hazards. Obey all safety messages that follow this symbol to avoid possible injury or 
death.

DANGER indicates a hazardous situation which, if not avoided, will result in death or serious 
injury.

! DANGER

WARNING indicates a hazardous situation which, if not avoided, could result in death or 
serious injury.

WARNING!

CAUTION indicates a hazardous situation which, if not avoided, could result in minor or 
moderate injury.

CAUTION!

NOTICE is used to address practices not related to physical injury.

NOTICE
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Cybersecurity Safety Notice

WARNING
POTENTIAL COMPROMISE OF SYSTEM AVAILABILITY, INTEGRITY, AND
CONFIDENTIALITY
• Change default passwords at first use to help prevent unauthorized access

to device settings, controls, and information.
• Disable unused ports/services and default accounts to help minimize

pathways for malicious attackers.
• Place networked devices behind multiple layers of cyber defenses (such as

firewalls, network segmentation, and network intrusion detection and
protection).

• Use cybersecurity best practices (for example, least privilege, separation of
duties) to help prevent unauthorized exposure, loss, modification of data and
logs, or interruption of services.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

FCC Notice
This equipment has been tested and found to comply with the limits for a Class A
digital device, pursuant to part 15 of the FCC Rules. These limits are designated
to provide reasonable protection against harmful interference when the equipment
is operated in a commercial environment. This equipment generates, uses, and
can radiate radio frequency energy and, if not installed and used in accordance
with the instruction manual, may cause harmful interference to radio
communications. Operation of this equipment in a residential area is likely to
cause harmful interference in which case the user will be required to correct the
interference at this own expense.

6 DOCA0223EN-02

Link150 Ethernet Gateway Firmware Upgrade Tool Safety Information



About the Book

Document Scope
The aim of this document is to provide the users, installers, and maintenance
personnel with the software solution to update the Link150 gateway to the latest
firmware version irrespective of the initial version. This guide must be used with
Link150 gateway.

Validity Note
This guide is valid for Link150 Firmware Upgrade Tool for use with Link150
gateway.

Online Information
The characteristics of the products described in this document are intended to
match the characteristics that are available on www.se.com. As part of our
corporate strategy for constant improvement, we may revise the content over time
to enhance clarity and accuracy. If you see a difference between the
characteristics in this document and the characteristics on www.se.com, consider
www.se.com to contain the latest information.

Related Documents
Title of Documentation Reference Number

Link150 Ethernet Gateway – User Guide DOCA0110EN

Link150 Ethernet Gateway – Release Note DOCA0182EN

Link150 Ethernet Gateway – Instruction Sheet NHA50221

You can download these technical publications and other technical information
from our website at www.se.com/ww/en/download/.
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Introduction

EcoStruxure Master Range
EcoStruxure is Schneider Electric’s IoT-enabled, plug-and-play, open,
interoperable architecture and platform, in Homes, Buildings, Data Centers,
Infrastructure and Industries. Innovation at Every Level from Connected Products
to Edge Control, and Apps, Analytics and Services.

Firmware Upgrade via Firmware Upgrade Tool
The Link150 Firmware Upgrade Tool provides the software solution to update the
Link150 gateway to the latest firmware version irrespective of the initial version.

The tool is included inside the Link150 firmware update (v5.3.7) package,
available as a ZIP file. Once extracted, the Mass Upgrade tool can be used to
initiate the firmware upgrade.

You can download the latest version of this tool from the Schneider Electric
website: https://www.se.com/in/en/download/document/FW_v5.3.7/. For the latest
version number of the tool, refer DOCA0304EN – Link 150 Ethernet Gateway
Firmware Upgrade Tool Release Notes.

The firmware update procedure is detailed in DOCA0223EN – Link150 Ethernet
Gateway Firmware Upgrade Tool – User Guide.
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Firmware Update Setup
Multiple Link150 devices can be simultaneously updated, only if the devices are all
connected in an Ethernet star network topology. Refer to the below graphical
representation.

NOTE:
• It is strongly recommended to exclude daisy chain connected devices

when performing updates of multiple devices simultaneously.
• It is not recommended to update the firmware of more than 32 devices at

a time.

WARNING
POTENTIAL COMPROMISE OF SYSTEM AVAILABILITY, INTEGRITYAND
CONFIDENTIALITY
• In a daisy chain setup, update the device firmware only one at a time. The

Link150 Firmware Upgrade Tool will not support firmware update of multiple
devices at a time.

• For firmware version 005.001.015 or later, it is strongly recommended to
enable HTTPS mode before starting the firmware update of Link150
gateways.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Ethernet
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Tool Configuration
Automatic discovery is not available in the firmware upgrade tool. The list of
Link150 gateways for which the firmware is to be updated are described and
written manually in a user-created .csv file.

Follow the standard rules of .csv file format when editing the configuration file.

An example of the .csv file is shown below:

Each line corresponds to one gateway. The three columns describe the IP
address of the gateway, user login account and password.

NOTICE
UNINTENDED ACCESS TO CONFIDENTIAL DATA
• Once all the devices are updated, encrypt the file and protect it with a

password to save the file integrity and confidentiality. Most compression
utilities can perform such operation.

• Store the encrypted archive file in a location on a PC or a network directory
where access controls are enforced to help prevent any unauthorized
access to the file.

Failure to follow these instructions can result in unauthorized or
unintended access to data.
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Procedure for Updating Link150 Firmware

Prerequisites
The following prerequisites are required for updating the firmware:

• Modbus TCP interface should be enabled
• Modbus TCP server port number should be 502
• FTP should be enabled for device with firmware version ≤ 005.001.015

Firmware Update Procedure

NOTICE
HAZARD OF EQUIPMENT DAMAGE
• The Link150 gateway must be continuously powered during the firmware

update.
• The connection with the Link150 gateway must be uninterrupted during the

firmware update.
Failure to follow these instructions can result in equipment damage.

Once the firmware update starts, all the options in the window will be disabled until
the firmware update process is completed. The device status is automatically
updated. Depending on the initial firmware version of a gateway, the firmware
update process can last from 5 to 15 minutes.

Follow the procedure to update the firmware of the Link150 gateway:

Step Action

1 Double-click the Link150fwupgradetool.exe file to open the Link150 Firmware Upgrade Tool.

NOTE: The Link150 Firmware Upgrade Tool is compatible with Microsoft® Windows® 10 and later.

2

Click icon to select the firmware version for update.

This action can also be done through Tools > Select Firmware.
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Step Action

3 Select the Link150_Delivery_Package_Vxxx.xxx.xxx.zip file and click OK. The xxx.xxx.xxx in the zip file name refers to the
latest firmware version.

NOTE: The Link150_Delivery_Package_Vxxx.xxx.xxx.zip file can be downloaded from www.se.com.

4

Click icon to select the .csv file.

This action can also be done through File > Open.
NOTE: The tool will load the data retrieved from all units:

• Current firmware versions
• Device status

5

Ensure that the required devices are selected and then click icon to start the firmware update of the gateway(s).

A safety message is displayed. Read the message and click I UNDERSTAND to continue.

This action can also be done through Tools > Upload Firmware.
NOTE:When the firmware update is completed, a new device version is displayed in the Exploit Version column.

6 Select the devices to verify the firmware consistency with the latest firmware version available.

7

Click icon to start the verification.

This action can also be done through Tools > Check FW Consistency.
NOTE: The recommendation as per device firmware information is available in the Status column .

8

Click icon to save the firmware update logs of selected devices.

9

Click icon to export the firmware update result.

Upgrade Status Error Messages

Status Message Description

Invalid device IP format Device IP mentioned in .csv file is not in standard IP format.

Device connection failed • Application could not connect to device while retrieving device information.
• Any connection exception occurred from the device.

Get device info operation failed Any exception occurred while retrieving the device information.

Device is not communicating Application is not able to read current device exploit version.

Upgrade not allowed Device version is greater than target firmware version.

Device firmware version not supported Target firmware version is not supported by the application.

Firmware upload failed Any error occurred during HTTP or FTP file transfer.
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As standards, specifications, and design change from time to time, please ask for confirmation
of the information given in this publication.
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