9.1.2 SP1 Upgrade Scripts - Oracle

The following implementation scripts must be run on your Responder Oracle database to add the correct tables, views, and indices to upgrade Responder to version 9.1.2 SP1. When upgrading Responder execute ONLY the Upgrade script(s) that fall between your previous release and the new release to which you are upgrading. Do NOT execute any Implementation Scripts.

Responder requires two schemas: Responder and Archive. Some scripts are run on the Responder schema and some on the Archive schema. In the list below, the schema on which the script should be executed is in parentheses.

  • 912sp1_01_MMTables_oracle.sql (Responder)

  1. Log in to the Responder schema as RESPONDER (i.e., schema owner). Use an application such as SQL Plus.
  2. Execute the 912sp1_01_MMTables_oracle.sql script by entering "@" followed by a path to the script (an example follows) and pressing Enter. This script assigns new model names to the appropriate database tables as required by Responder.
    @ D:\Program Files\Miner and Miner\Responder\Developer Resources\
    9.1.2 - 9.1.2 SP1 Upgrade Scripts\Oracle\912sp1_01_MMTables_oracle.sqlx
This script assigns the ARCFMHIDDENTABLE model name to the RX_Element_Locks and RX_Pending_Element_Locks tables. This corrects an issue that cause ArcCatalog to crash when the user right-clicked either of these tables. This script is NOT necessary for SQL servers.
QR code for this page

Was this helpful?