9.2.1 Upgrade Scripts - Oracle

The following implementation scripts must be run on your Responder Oracle database to add the correct tables, views, and indices to upgrade Responder to version 9.2.1. When upgrading Responder execute ONLY the Upgrade script(s) that fall between your previous release and the new release to which you are upgrading. Do NOT execute any Implementation Scripts.

Responder requires two schemas: Responder and Archive. Some scripts are run on the Responder schema and some on the Archive schema. In the list below, the schema on which the script should be executed is in parentheses.

  • 921_01_RxTables_oracle.sql (Responder)

  • 921_02_ArchiveTables_oracle.sql (Archive)

  1. Log in to the Responder schema as RESPONDER (i.e., schema owner). Use an application such as SQL Plus.
  2. Execute the 921_01_RxTables_oracle.sql script by entering "@" followed by a path to the script (an example follows) and pressing Enter. This script creates the database tables required by Responder.
    @ D:\Program Files\Miner and Miner\Responder\Developer Resources\
    9.2.0 SP3 - 9.2.1 Upgrade Scripts\Oracle\921_01_RxTables_oracle.sql
  3. Log in to the Archive schema as ARCHIVE (i.e., schema owner).
  4. Execute the 921_02_ArchiveTables_oracle.sql script in the same manner as the first script. Enter "@" followed by a path to the script and press Enter. This script creates the database tables required by Responder Archive Explorer.
QR code for this page

Was this helpful?